<!doctype html >
<html xmlns="http://www.w3.org/1999/xhtml"  class="">
<head>











<!-- ========= Meta Tags ========= -->

<meta http-equiv="Content-type" content="text/html;charset=utf-8">
<meta charset="utf-8">
<link rel="canonical" href="/the-gpl-in-laymans-terms-free-as-in-what">
<meta id="view" name="viewport" content=", initial-scale=1, minimum-scale=1, maximum-scale=1, user-scalable=0" />
<meta name="apple-mobile-web-app-capable" content="yes">

<!--Add favorites icons-->
<link rel="apple-touch-icon" href="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/xray57-57x57.png"/><link rel="apple-touch-startup-image" href="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/xray640-640x1096.png"/>
	<link rel="icon" type="image/x-icon" href="https://irp-cdn.multiscreensite.com/58a25abc/site_favicon_16_1484197195865.ico"/>
	
<!-- End favorite icons -->

<!--  render the required CSS and JS in the head section -->

	











<!-- ========= CSS Section ========= -->
<!-- Foundation CSS -->
<link rel="stylesheet" type="text/css" href="/_dm/s/rt/dist/css/d-css-foundation.min.css?version=2017-07-23T09_26_21" />

	
<!-- Google Fonts Include -->


<link rel="stylesheet" type="text/css" href="/_dm/s/rt/dist/css/css-font-package.min.css?version=2017-07-23T09_26_21" />

<!-- RT CSS Include d-css-runtime-desktop-one-package-new-->
<link rel="stylesheet" type="text/css" href="/_dm/s/rt/dist/css/d-css-runtime-desktop-one-package-new.min.css?version=2017-07-23T09_26_21" />

<!-- End of RT CSS Include -->



<!-- Site CSS -->
<link type="text/css" rel="stylesheet" href="//irp-cdn.multiscreensite.com/58a25abc/files/58a25abc_1.min.css?v=171"/>
<style id="customWidgetStyle" type="text/css">

</style>
<style id="additionalGlobalCss" type="text/css"></style>
<style id="pagestyle" type="text/css"> 
*#dm *.dmBody div.u_1748627106{background-color:rgb(242, 242, 242) !important;}
*#dm *.dmBody div.u_1862607520 *.postArticle> *.inner{background-color:rgb(255, 255, 255) !important;}
*#dm *.dmBody div.u_1477462643 ul.dmNavWrapper> li> a *.navText{font-family:'Courier New' !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1477462643 ul.dmNavWrapper> li> a *.navItemText{font-family:'Courier New' !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1477462643 ul.dmNavWrapper> li> *.dmNavigation{font-family:'Courier New' !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li.navItemSelectedServer> a{border-bottom-width:0px !important;border-bottom-style:solid !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li.dmNavItemSelected> a{border-bottom-width:0px !important;border-bottom-style:solid !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li.navItemSelectedServer> a *.navText{font-weight:normal !important;text-decoration:underline !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li.dmNavItemSelected> a *.navItemText{font-weight:normal !important;text-decoration:underline !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li.dmNavItemSelected> *.navItemText{font-weight:normal !important;text-decoration:underline !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li> a *.navText{font-family:Lato !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li> a *.navItemText{font-family:Lato !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper> li> *.dmNavigation{font-family:Lato !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1647440349 ul.dmNavWrapper{padding-right:0px !important;margin-left:0px !important;padding-left:0px !important;}
*#dm *.dmBody *.u_1647440349 ul.dmNavWrapper> li> a{margin-left:10px !important;margin-right:10px !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li.navItemSelectedServer> a{border-bottom-width:0px !important;border-bottom-style:solid !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li.dmNavItemSelected> a{border-bottom-width:0px !important;border-bottom-style:solid !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li.navItemSelectedServer> a *.navText{font-weight:normal !important;text-decoration:underline !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li.dmNavItemSelected> a *.navItemText{font-weight:normal !important;text-decoration:underline !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li.dmNavItemSelected> *.navItemText{font-weight:normal !important;text-decoration:underline !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li> a *.navText{font-family:Lato !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li> a *.navItemText{font-family:Lato !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper> li> *.dmNavigation{font-family:Lato !important;font-weight:normal !important;}
*#dm *.dmBody div.u_1627169146 ul.dmNavWrapper{padding-right:0px !important;margin-left:0px !important;padding-left:0px !important;}
*#dm *.dmBody *.u_1627169146 ul.dmNavWrapper> li> a{margin-left:10px !important;margin-right:10px !important;}
</style>

<style id="pagestyleDevice" type="text/css"> 
*#dm *.dmBody div.u_1413385349{padding-top:30px !important;padding-bottom:30px !important;}
*#dm *.dmBody div.u_1501238740{padding-top:0px !important;padding-left:0px !important;padding-bottom:0px !important;float:none !important;margin-right:0px !important;margin-left:0px !important;top:0px !important;max-width:calc(100% - 0px) !important;left:0px !important;width:481px !important;margin-top:0px !important;position:relative !important;margin-bottom:10px !important;padding-right:0px !important;min-width:25px !important;text-align:start !important;height:auto !important;}
*#dm *.dmBody div.u_1570747739{padding-top:0px !important;padding-left:0px !important;padding-bottom:0px !important;float:none !important;margin-right:0px !important;margin-left:0px !important;top:0px !important;max-width:calc(100% - 0px) !important;left:0px !important;width:100% !important;margin-top:15px !important;position:relative !important;margin-bottom:0px !important;padding-right:0px !important;min-width:25px !important;text-align:start !important;height:auto !important;}
body.dmDesktopBody *.d-header-wrapper{display:none !important;}
body.dmDesktopBody *.popupNavBox{display:none !important;}
*#dm *.dmBody div.u_1477462643 ul.dmNavWrapper> li> a *.navText{font-size:18px !important;}
*#dm *.dmBody div.u_1477462643 ul.dmNavWrapper> li> a *.navItemText{font-size:18px !important;}
*#dm *.dmBody div.u_1477462643 ul.dmNavWrapper> li> *.dmNavigation{font-size:18px !important;}
body.dmTabletBody *.d-header-wrapper{display:none !important;}
body.dmTabletBody *.popupNavBox{display:none !important;}
*#dm *.dmBody div.u_1212308306{padding-top:15px !important;padding-bottom:15px !important;}
*#dm *.dmBody div.u_1414499623{padding-top:20px !important;padding-left:46.5px !important;padding-bottom:34px !important;float:none !important;margin-right:auto !important;margin-left:auto !important;top:auto !important;max-width:none !important;left:0 !important;width:100% !important;margin-top:0px !important;position:relative !important;margin-bottom:0px !important;padding-right:46.5px !important;min-width:0 !important;text-align:start !important;height:auto !important;}
</style>

<!--[if IE 7]><style>.fw-head.fw-logo img{max-width: 290px;}.dm_header .logo-div img{max-width: 290px;}</style><![endif]-->
<!--[if IE 8]><style>.fw-head .fw-logo img{max-width: 290px;}.dm_header .logo-div img{max-width: 290px;}*#dm div.dmHeader{_height:90px;min-height:0px;}</style><![endif]-->

	















<!-- ========= JS Section ========= -->

<!-- Modernizr -->
<script>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</script>



<!-- Custom Widgets js functions map -->
<script>
window.customWidgetsFunctions = {};
window.customWidgetsStrings = {};
</script>


<script type="text/javascript">

var version = "3.0.2";
var build = "2017-07-23T09_26_21";


	function buildEditorParent(){
		window.isMultiScreen = true;
		window.editorParent = {};
		window.previewParent = {};
		window.assetsCacheQueryParam="?version=2017-07-23T09_26_21";
		try {
		 var _p = window.parent;
		 if (_p && _p.document && _p.$ && _p.$.dmfw){window.editorParent = _p;}
		 else if (_p.isSitePreview){window.previewParent = _p;}
		} catch (e) {
			
		}
	}

	buildEditorParent();


</script>
<!-- Load jQuery -->
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<!-- End Load jQuery -->


<script>
	window.cookiesNotificationMarkupPreview = '';
</script>
<!-- HEAD RT JS Include -->
<script>
window.INSITE = window.INSITE || {};
window.INSITE.device = "desktop";
window.rtCommonProps = {};
rtCommonProps["rt.ajax.ajaxScriptsFix"]=true;
rtCommonProps["rt.pushnotifs.sslframe.encoded"]='aHR0cHM6Ly97c3ViZG9tYWlufS5wdXNoLW5vdGlmcy5jb20=';
rtCommonProps["facebook.accessToken"]='126515034112906|8vv7JhnEegS8qz43fIOZjxGZReA';
rtCommonProps["performance.tabletPreview.removeScroll"]='false';
rtCommonProps["inlineEditGrid.snap"]=true;
rtCommonProps["popup.insite.cookie.ttl"]='0.0';
rtCommonProps["rt.pushnotifs.force.button"]=true;
rtCommonProps["google.places.key"]='AIzaSyBAwUOqPUB1CU31yDztoZYaUE7sPv4ktEI';
rtCommonProps["common.mapbox.token"]='pk.eyJ1IjoiZGFubnliMTIzIiwiYSI6ImNqMGljZ256dzAwMDAycXBkdWxwbDgzeXYifQ.Ck5P-0NKPVKAZ6SH98gxxw';
rtCommonProps["common.mapbox.js.override"]=false;
rtCommonProps["common.opencage.token"]='319e14f32bcce967ba55cd263478796d';
rtCommonProps["common.here.appId"]='iYvDjIQ2quyEu0rg0hLo';
rtCommonProps["common.here.appCode"]='1hcIxLJcbybmtBYTD9Z1UA';

rtCommonProps["common.mapsProvider"]='mapbox';
rtCommonProps["common.geocodeProvider"]='here';
</script>
<script src="/_dm/s/rt/dist/scripts/d-js-runtime-one-package.min.js?version=2017-07-23T09_26_21" ></script>


<script type="text/javascript">
  var onCaptchaLoad = function() {
    $.DM.initFormCaptcha();
  };
</script>
<script src="https://www.google.com/recaptcha/api.js?onload=onCaptchaLoad&render=explicit" async defer></script>


<!-- End of HEAD RT JS Include -->




<script src="/_dm/s/rt/dist/scripts/d-js-one-runtime-layouts-package.min.js?version=2017-07-23T09_26_21" ></script>

<script src="/_dm/s/rt/dist/scripts/d-js-one-runtime-layouts-desktop.min.js?version=2017-07-23T09_26_21" ></script>

<script>jQuery.DM.updateWidthAndHeight();
$(window).resize(function() {jQuery.DM.updateWidth();});
$(window).bind("orientationchange",function(e) {jQuery.DM.updateWidth();jQuery.layoutManager.initLayout();});
$(document).resize(function() {jQuery.DM.updateWidth();});
</script>




	

<!--  End render the required css and JS in the head section -->








  <link type="application/rss+xml" rel="alternate" href="http://www.darrentoback.com/feed/rss2"/>
  <link type="application/atom+xml" rel="alternate" href="http://www.darrentoback.com/feed/atom"/>
  <meta name="twitter:title" content="The GPL in Layman’s Terms - Free as in What?"/>
  <meta name="twitter:description" content="Through the glazed-over eyes of friends and family, past that painful look of well-intended but feigned interest, I can clearly see a fundamental lack of understanding about this free software I’m constantly going on about."/>
  <meta name="twitter:image:src" content="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/copyleft-720x624.jpg"/>
  <meta name="article:published_time" content="2017-01-19T20:28Z"/>
  <meta property="og:description" content="Through the glazed-over eyes of friends and family, past that painful look of well-intended but feigned interest, I can clearly see a fundamental lack of understanding about this free software I’m constantly going on about."/>
  <meta property="og:url" content="http://www.darrentoback.com/the-gpl-in-laymans-terms-free-as-in-what"/>
  <meta property="og:title" content="The GPL in Layman’s Terms - Free as in What?"/>
  <meta property="og:image" content="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/copyleft-720x624.jpg"/>
  <title>
    
    The GPL in Layman’s Terms - Free as in What?
  
  </title>
  <meta name="description" content="Through the glazed-over eyes of friends and family, past that painful look of well-intended but feigned interest, I can clearly see a fundamental lack of understanding about this free software I’m constantly going on about."/>
  <meta name="keywords" content="linux, bsd, software, hardware, python, javascript, ubuntu, mint, slackware, red hat, fedora, arch, manjaro, debian"/>

</head>






<body id="dmRoot" class="supportsFontIcons dmRoot dmDesktopBody dmLargeBody " style="overflow:auto;padding:0;margin:0;float:none;"  >




<div id="disabledImageZone" style="display:none;z-index:-1">
<style type="text/css">
	#imageZone{position:absolute;margin:auto;}
	.coloumns{border-radius:3px;background-color:rgb(249,152,13);/*border:1px solid #999;*/ height:18px;width:6px;-webkit-animation-name:loader;-webkit-animation-duration:1s;-webkit-animation-iteration-count:infinite;-webkit-animation-direction:linear;-moz-animation-name:loader;-moz-animation-duration:1s;-moz-animation-iteration-count:infinite;-moz-animation-direction:linear;opacity:.25;-webkit-transform:scale(0.7);-webkit-transform-origin:50% 180%;-moz-transform:scale(0.7);-moz-transform-origin:50% 180%;position:absolute;}
	#coloumn1{-webkit-transform:rotate(0deg);-webkit-animation-delay:-.914s;-moz-transform:rotate(0deg);-moz-animation-delay:-.914s;}
	#coloumn2{-webkit-transform:rotate(30deg);-webkit-animation-delay:-.831s;-moz-transform:rotate(30deg);-moz-animation-delay:-.831s;}
	#coloumn3{-webkit-transform:rotate(60deg);-webkit-animation-delay:-.747s;-moz-transform:rotate(60deg);-moz-animation-delay:-.747s;}
	#coloumn4{-webkit-transform:rotate(90deg);-webkit-animation-delay:-.664s;-moz-transform:rotate(90deg);-moz-animation-delay:-.664s;}
	#coloumn5{-webkit-transform:rotate(120deg);-webkit-animation-delay:-.581s;-moz-transform:rotate(120deg);-moz-animation-delay:-.581s;}
	#coloumn6{-webkit-transform:rotate(150deg);-webkit-animation-delay:-.498s;-moz-transform:rotate(150deg);-moz-animation-delay:-.498s;}
	#coloumn7{-webkit-transform:rotate(180deg);-webkit-animation-delay:-.415s;-moz-transform:rotate(180deg);-moz-animation-delay:-.415s;}
	#coloumn8{-webkit-transform:rotate(210deg);-webkit-animation-delay:-.332s;-moz-transform:rotate(210deg);-moz-animation-delay:-.332s;}
	#coloumn9{-webkit-transform:rotate(240deg);-webkit-animation-delay:-.249s;-moz-transform:rotate(240deg);-moz-animation-delay:-.249s;}
	#coloumn10{-webkit-transform:rotate(270deg);-webkit-animation-delay:-.166s;-moz-transform:rotate(270deg);-moz-animation-delay:-.166s;}
	#coloumn11{-webkit-transform:rotate(300deg);-webkit-animation-delay:-.083s;-moz-transform:rotate(300deg);-moz-animation-delay:-.083s;}
	#coloumn12{-webkit-transform:rotate(330deg);-moz-transform:rotate(330deg);}
	@-webkit-keyframes loader {0%{opacity:1;}100%{opacity:.25;}}
	@-moz-keyframes loader {0%{opacity:1;}100%{opacity:.25;}}
</style>
<div id='imageZone'><div id='coloumn1' class='coloumns'></div><div id='coloumn2' class='coloumns'></div><div id='coloumn3' class='coloumns'></div><div id='coloumn4' class='coloumns'></div><div id='coloumn5' class='coloumns'></div><div id='coloumn6' class='coloumns'></div><div id='coloumn7' class='coloumns'></div><div id='coloumn8' class='coloumns'></div><div id='coloumn9' class='coloumns'></div><div id='coloumn10' class='coloumns'></div><div id='coloumn11' class='coloumns'></div><div id='coloumn12' class='coloumns'></div>
</div></div>

<!-- ========= Site Content ========= -->
<div id="dm" class='dmwr'>
<div class="dm_wrapper standard-var5 widgetStyle-3 standard"> 
 <div dmwrapped="true" id="1227679226"> <div dmtemplateid="skinnyHeaderLayout" class="skinnyHeaderLayout dm-bfs dm-layout-sec hasAnimations dmPageBody d-page-1680341264 dmFreeHeader" id="dm-outer-wrapper" data-page-class="1680341264" data-buttonstyle="THICK_BORDER" data-background-image="url(https://dd-cdn.multiscreensite.com/themes/amelie/amelie-hp-main-image.jpg)" data-background-hide-inner="true" data-background-fullbleed="false"> <div id="dmStyle_outerContainer" class="dmOuter"> <div id="dmStyle_innerContainer" class="dmInner"> <div class="dmLayoutWrapper standard-var dmStandardDesktop"> <ul class="dmn dmLayoutNav hiddenNavPlaceHolder navPlaceHolder dmDisplay_None"></ul> 
 <div class="dmHeaderContainer fHeader d-header-wrapper"> <div id="hcontainer" class="dmHeader p_hfcontainer" freeheader="true"> <div dm:templateorder="75" class="dmHeaderResp dmHeaderStack noSwitch" id="1692011211"></div> 
</div> 
</div> 
 <div id="desktopBodyBox"> <div id="iscrollBody"> <div id="site_content"> <div class="dmRespRow dmRespRowStable dmRespRowNoPadding dmPageTitleRow dmInnerBarRow"> <div class="dmRespColsWrapper"> <div class="large-12 dmRespCol"> <div id="innerBar" class="innerBar lineInnerBar dmDisplay_None"> <div class="titleLine display_None"><hr/></div> 
<!-- Page title is hidden in css for new responsive sites. It is left here only so we don't break old sites. Don't copy it to new layouts --> <div id="pageTitleText"></div> 
 <div class="titleLine display_None"><hr/></div> 
</div> 
</div> 
</div> 
</div> 
 <div dmwrapped="true" id="1227679226" class="dmBody u_dmStyle_template_d1-internal-blog-post"> <div id="allWrapper" class="allWrapper"><!-- navigation placeholders --> <div id="dm_content" class="dmContent"> <div dm:templateid="DudaBlogPostTemplateResp" class="generalRespTmplWrapper dmRespRowsWrapper innerPageTmplBox storeDefaultPage" id="1680341264"> <div class="u_1212308306 dmRespRow" style="text-align: center;" id="1212308306"> <div class="dmRespColsWrapper" id="1143872599"> <div class="dmRespCol small-12 medium-12 large-12" id="1845660489"> <span id="1567248821"></span> 
 <div class="default u_1627169146 dmLinksMenu desktopNavWrapper" id="1627169146" dmle_extension="onelinksmenu" wr="true" navigation_id="" icon="true" surround="true" adwords="" data-from-nav="true" data-sub-nav="true" data-middle-logo-nav="false" data-items="2" custom-li-class="" custom-ul-class="" custom-a-class="" custom-inner-ul-class="" custom-nested-inner-ul-class="" custom-span-class=""> <ul class="dmNavWrapper dmn menuContainer "> <li class=" desktopTopNav navListLi navButtonLi   "> <a href="/home" class="dmUDNavigationItem_00 " target="" data-target-page-alias=""> <span class="navItemText ">Home</span> 
</a> 
</li> 
 <li class=" desktopTopNav navListLi navButtonLi   "> <a href="/about-me" class="dmUDNavigationItem_010101522144 " target="" data-target-page-alias=""> <span class="navItemText ">About Me</span> 
</a> 
</li> 
</ul> 
</div> 
</div> 
</div> 
</div> 
 <div class="u_1414499623 dmRespRow" id="1414499623"> <div class="dmRespColsWrapper" id="1594877404"> <div class="dmRespCol small-12 medium-12 large-12" id="1240328710"> <div data-blog-component="post" id="1455125172" class="blog-post-tmpl blog-post gpl free software copyleft license bsd linux development" dmle_extension="internal_blog_post" wr="false" data-dmtmpl="true" icon="true" surround="false"> <style id="post-2590c36-style"></style> 
 <div data-blog-component="title" id="post-2590c36-title" class="blog-post-component blog-post-component-title"> <style id="post-2590c36-title-style">#post-2590c36-title .inner-title{ text-align: left;font-weight: normal; }#post-2590c36-title .inner-post-details{ text-align: left; }</style> 
 <div> <h1 data-blog-inner="title" class="inner-title">The GPL in Layman&rsquo;s Terms - Free as in What?</h1> 
 <ul data-blog-inner="post-details" class="inner-post-details"> <li><span>By</span><span>&nbsp;</span><span>- dmt</span></li> 
 <li>&bull;</li> 
 <li>19 Jan, 2017</li> 
 <li>&bull;</li> 
 <li> <span class="blog-post-comments-count" data-disqus-id="58a25abc~281505" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/the-gpl-in-laymans-terms-free-as-in-what" data-comment="Comment" data-comments="Comments"></span> 
</li> 
</ul> 
</div> 
</div> 
 <div data-blog-component="image" id="post-component-ee39843" class="blog-post-component blog-post-component-image"> <style id="post-component-ee39843-style">#post-component-ee39843 .inner-figure{ text-align: center; }#post-component-ee39843 .inner-image{ max-width: 100%;width: 50%; }</style> 
 <figure data-blog-inner="figure" class="inner-figure"><img data-blog-inner="image" class="inner-image" src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/copyleft-720x624.jpg" onerror="handleImageLoadError(this)"/> <figcaption data-blog-inner="caption" class="inner-caption"> <i></i> 
</figcaption> 
</figure> 
</div> 
 <div data-blog-component="text" id="post-component-7f39746" class="blog-post-component blog-post-component-text"> <style id="post-component-7f39746-style">#post-component-7f39746 .inner-paragraph{ text-align: left; }</style> 
 <div data-blog-inner="text" class="inner-paragraph">Through the glazed-over eyes of friends and family, past that painful look of well-intended but feigned interest, I can clearly see a fundamental lack of understanding about this free software I&rsquo;m constantly going on about. I&rsquo;ve always been the frugal type, so I think they just assume I choose it for the price. Ironically, I would happily pay for the free software programs I use daily, they just happen to come at no cost. And anyway, I DO pay.. just not to ACME Software Company for the yearly subscription. I go straight to the donation links of developers who write awesome code and pay them directly. It makes someone&rsquo;s day, feels <i>way</i> 
better than hitting &ldquo;BUY&rdquo; at the neighborhood app store, and costs only what I feel it&rsquo;s worth. Some days that&rsquo;s a little, other days it&rsquo;s more.<br/><br/>Returning to the reason for this essay, I decided to fix this disconnect and explain to those around me where the passion for using and sharing free software comes from. That decision turned into an open letter, which turned into this post. It was surprisingly difficult to distill the essence of a passion that has so many sides, and a winding road brought me to the conclusions herein. As with any other discipline, programming has endless details abound that only interest the initiated (hence blogs), and I only wanted to talk about why <b>I</b> 
think it&rsquo;s so important for <b>other people</b> 
to use free software, so I had to triple-distill my logic. I&rsquo;ll provide a bit of background first, then explain what I mean.<br/><br/> <b>Free vs <i>Free</i> 
</b> 
- Most people get &ldquo;free&rdquo;. If I say, &ldquo;go download Firefox, it&rsquo;s free&rdquo;, you understand that you won&rsquo;t have to run your credit card to get the download. However, in software licensing there&rsquo;s another kind of <i>free</i> 
that&rsquo;s more difficult to grasp at first. The romance languages have different words for each type of <i>free</i> 
, &ldquo;gratis&rdquo; for free as in you got something of value without paying for it, and &ldquo;libre&rdquo; for free as in liberty or the opposite of being locked up. This is reflected in the naming of open source programs like <a href="https://www.libreoffice.org/" target="_top">LibreOffice</a> 
and many others. In the software world, when you hear &ldquo;free as in beer&rdquo;, it means gratis. When you hear &ldquo;free as in speech&rdquo; or &ldquo;free as in freedom&rdquo;, it means libre. This distinction is important to understand because a computer program can be free to download, but not free at all in terms of studying its code or recycling it into another program (a good example being the freeware application Adobe Reader).<br/><br/>We are unable to study the workings of many major computer programs because the code is copyrighted and kept secret like the baked bean recipe only that dog knows (will he reveal it?). This kind of proprietary licensing scheme grants the user the right to use the program (through the ubiquitous <a href="https://en.wikipedia.org/wiki/End-user_license_agreement" target="_top">EULA</a> 
), but not the right to see the code or even own the program - ownership stays with the developer while you just use it. Conversely, for each open source computer program written and published, software developers choose a license that covers what can and cannot be done with the code. There are several dozen free and <a href="https://en.wikipedia.org/wiki/Comparison_of_free_and_open-source_software_licenses" target="_top">open source licenses</a> 
to choose from, each defining a different set of rules (or complete lack of rules) regarding how that code can be re-used. Some restrict the re-use of the software, while <a href="https://en.wikipedia.org/wiki/WTFPL" target="_top">others</a> 
don&rsquo;t. Incidentally, software can also be dedicated to the <a href="https://en.wikipedia.org/wiki/Public_domain" target="_top">Public domain</a> 
in lieu of being licensed at all.<br/><br/>In the late 1980s, the first open source licenses started to appear. The one that broke ground and led to the abundant collection of high-quality, open source programs available today is the Gnu General Public License ( <a href="https://en.wikipedia.org/wiki/GNU_General_Public_License" target="_top">GPL</a> 
). What made this licensing approach revolutionary at the time is that it granted users of a computer program the rights laid out in the <a href="https://en.wikipedia.org/wiki/The_Free_Software_Definition" target="_top">Free Software Definition</a> 
(the ability to use, study, change and redistribute the software) while requiring derivative works to be licensed under the same terms. This is known as a <a href="https://en.wikipedia.org/wiki/Copyleft" target="_top">copyleft</a> 
license and is considered &ldquo;protective&rdquo; because it preserves the rights in derivative works. This license ensures that a developer&rsquo;s code won&rsquo;t get locked up in someone else&rsquo;s alternatively re-licensed release of the original code. Using this license let&rsquo;s the developer share her code without worry that it will be used against her wishes down the road. The freedom to code without this worry started a software development rush that continues to this day. The results of this rush are a testament to the skill and tenacity of open source developers, and their fruits are proof that the open development model is a superior one.<br/><br/>Known as &quot;permissive&quot;, there are also open sources licenses that don&rsquo;t have such restrictions. The <a href="https://en.wikipedia.org/wiki/BSD_licenses" target="_top">BSD license</a> 
is a prime example of a permissive license. These licenses grant the user the right re-use the code in any program, even a proprietary one. For this reason, large companies will target code released under BSD-style licenses for re-use in proprietary software they have no intention of opening up. In recent years, legal challenges have been successfully leveled against companies for re-using software in violation of the GPL. This has resulted in a renewed and long-deserved respect for the terms of the GPL, and nowadays more companies are complying out of the gate when releasing new software (or just using BSD-licensed code).<br/><br/> <b>So Why Use Free Software?</b> 
- Returning again to the point here (and aware that opinions differ), I strongly believe that developing and releasing code into the open for peer review results in software of a higher quality, that runs faster, more safely and securely, with less problems, getting quicker bug fixes and providing more respect for user privacy than anything in the proprietary world. Indeed, both Apple and Google, who can easily afford their own in-house software development, instead chose to build their respective mobile platforms on top of existing open source operating systems: <a href="https://en.wikipedia.org/wiki/Linux" target="_top">Linux</a> 
for Android and the BSD-derived <a href="https://en.wikipedia.org/wiki/Darwin_(operating_system)" target="_top">Darwin</a> 
for iOS. If it&rsquo;s good enough for them, I think we can make it work on your desktop to read email, play music, video chat with friends, push office docs around, use the web with all the popular plugins, edit images, shop, bank, etc, etc.<br/></div> 
</div> 
 <div data-blog-component="image" id="post-component-6e078a5" class="blog-post-component blog-post-component-image"> <style id="post-component-6e078a5-style">#post-component-6e078a5 .inner-figure{ text-align: center; }#post-component-6e078a5 .inner-image{ max-width: 100%; }</style> 
 <figure data-blog-inner="figure" class="inner-figure"><img data-blog-inner="image" class="inner-image" src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/linux-1600x900.png" onerror="handleImageLoadError(this)"/> <figcaption data-blog-inner="caption" class="inner-caption"> <i>Modern Linux distribution running desktop apps</i> 
</figcaption> 
</figure> 
</div> 
 <div data-blog-component="text" id="post-component-36183bf" class="blog-post-component blog-post-component-text"> <style id="post-component-36183bf-style">#post-component-36183bf .inner-paragraph{ text-align: left; }</style> 
 <div data-blog-inner="text" class="inner-paragraph">These are the reasons I want to get the people I care about (and everyone else) onto a free 
OS like Linux, running all the fully-functional, 
professional-grade, freely-licensed programs available for work and 
play. In my frustration at failing to convert more people (I did get one
 person to switch - thanks Dad!), I was slow to realize that in not 
understanding the intricacies of software development, they really 
didn&rsquo;t see any obvious reason to switch and they were always wrong about
 why I was trying to convert them. This post aims to present my case, 
and maybe those around me will start to see that I&rsquo;m not trying to save 
them money (although why not?) and I&rsquo;m not trying to make them join the elite geekster club, I&rsquo;m just trying to open their eyes to the many 
benefits of using open source software.<br/><br/>Just a few short years 
ago, even the best open source software available still needed work - 
things looked rough, I won&rsquo;t lie. But now the software has matured to 
the point where the programs available in any Linux distribution rival 
and even surpass their proprietary counterparts in quality, and by every other measure as well.<br/><br/>dmt<br/></div> 
</div> 
 <footer data-blog-inner="footer"><div class="timeline-post prev-post"> <a class="prev-post" href="/this-script-updates-hosts-files-using-a-multi-source-unified-block-list-with-whitelisting">&larr; Older Post</a> 
</div><div class="timeline-post next-post"> <a class="next-post" href="/your-computer-s-clipboard-is-a-security-problem-fix-it-in-linux-with-xsel-and-cron">Newer Post &rarr;</a> 
</div></footer> 
</div> 
 <div class="default disqusWidget" id="1061459857" dmle_extension="disqus" wr="true" disqusurl="" disquscontainerid="" disqusidentifier="" shortname="dmt-linux" icon="true" surround="true" adwords=""> <div id="disqus_thread" class="disqusInited" language="en" shortname="dmt-linux" disqusurl="http://www.darrentoback.com/the-gpl-in-laymans-terms-free-as-in-what" disqus_identifier="" disqus_container_id=""></div> 
</div> 
</div> 
</div> 
</div> 
 <div class="u_1413385349 dmRespRow" id="1413385349"> <div class="dmRespColsWrapper" id="1951348051"> <div class="dmRespCol small-12 medium-12 large-12" id="1699932289"> <div class="u_1501238740 dmShare dmNoMark dmShareDesktop clearfix" id="1501238740" dmle_extension="shareextension" wr="false" data-dmtmpl="true" icon="true" surround="false" description="Share" icon-name="icon-share" facebook="true" twitter="true" google_plus="true" email="true" like="true" use_new_design="true" use_popup="true" linked_in="true" design="large" share_button_text="Share"><!-- 	Facebook Share --> <div data-target="facebook" class="shareLink fbShare clickTarget" data-href="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.darrentoback.com%2Fthe-gpl-in-laymans-terms-free-as-in-what"> <span class="icon-facebook shareText">Share</span> 
</div> 
<!-- 	Twitter Share --> <div data-target="twitter" class="shareLink twitterShare clickTarget" data-href="http://twitter.com/intent/tweet?text=I wanted to share this great website with you&url=http%3A%2F%2Fwww.darrentoback.com%2Fthe-gpl-in-laymans-terms-free-as-in-what"> <span class="icon-twitter shareText">Tweet</span> 
</div> 
<!-- 	Linkedin Share --> <div data-target="linkedin" class="shareLink linkedinShare clickTarget" data-href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.darrentoback.com%2Fthe-gpl-in-laymans-terms-free-as-in-what&title=I wanted to share this great website with you"> <span class="icon-linkedin shareText">Share</span> 
</div> 
<!-- 	G+ Share --> <div data-target="gplus" class="shareLink gplusShare clickTarget" data-href="https://plus.google.com/share?url=http%3A%2F%2Fwww.darrentoback.com%2Fthe-gpl-in-laymans-terms-free-as-in-what"> <span class="icon-google-plus shareText">Share</span> 
</div> 
<!-- 	Email Share --> <div data-target="email" class="shareLink emailShare clickTarget" data-href="/_dm/s/rt/actions/emailshare?text=I wanted to share this great website with you&site=http%3A%2F%2Fwww.darrentoback.com%2Fthe-gpl-in-laymans-terms-free-as-in-what&class=insidePopUp"> <span class="icon-envelope shareText">Mail</span> 
</div> 
</div> 
</div> 
</div> 
</div> 
 <div class="u_1748627106 dmRespRow" id="1748627106"> <div class="dmRespColsWrapper" id="1905658084"> <div class="dmRespCol small-12 medium-12 large-12" id="1213474049"> <div class="dmNewParagraph" data-dmtmpl="true" id="1056989218" style="transition: opacity 1s ease-in-out 0s;"><b><span style="text-decoration: underline;"><span style="font-weight: 700;">ALL POSTS:</span></span></b><br/></div> <div class="u_1862607520 mainBlog large_list" id="1862607520" dmle_extension="internal_blog_list" wr="false" action-text="Continue reading" postspadding="10" trim-title="false" posts-per-row="2" data-dmtmpl="true" show-author="true" show-images="false" posts-padding="10" text-box-padding="true" show-blog-title="false" posts-animation="fadeInUp" text-align="left" icon="true" surround="false" list-layout="large_list" visible-items="10" visible-post-lines="3" search-tags="" search-term="" more-posts-text="More Posts" header-type="H1"> <h1 class="blog-name">DMT/Linux Blog</h1> 
 <div class="inner clearfix"> <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 200.0ms;"> <a dont-color-link="true" href="/your-computer-s-clipboard-is-a-security-problem-fix-it-in-linux-with-xsel-and-cron"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/clip2-630x520.png)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/clip2-630x520.png" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/your-computer-s-clipboard-is-a-security-problem-fix-it-in-linux-with-xsel-and-cron">Your Computer's Clipboard is a Security Problem - Fix it in Linux with xsel and cron</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>21 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~282985" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/your-computer-s-clipboard-is-a-security-problem-fix-it-in-linux-with-xsel-and-cron" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription"> <b>EDIT: The original article recommended xsel, but a couple of users reported that it disabled their sound. This wasn't a problem for me, but I found another way (using <a href="https://github.com/astrand/xclip" target="_top">xclip</a> 
) to achieve the same goal that should sidestep the issue. The article has been updated to reflect the switch to xclip.</b> 
<br/><br/>The ability to copy/paste around your OS is essential. Whether you're writing code or comedy, these two functions are central to working with text on a computer. When you copy text, it goes into the memory-residing clipboard. Unless you install a clipboard manager that can hold multiple entries, the clipboard by default holds one <i>copy</i> 
event, and the moment you <i>copy</i> 
something else, the entry before it vanishes. In the standard Linux setup, the clipboard contents are stored in the memory of the program controlling it (most often Xorg).<br/><br/>The clipboard should be hobbled because any program can read its contents, and if left alone, it doesn't forget what it knows. Furthermore, modern browsers enable multiple ways for malicious websites to read from (and write to) your clipboard.<br/><br/>Although never the default, browsers have settings to disallow clipboard access. Add-ons for both browser and OS are available to manage your clipboard, as well, but it's easier and more reliable to fix the problem at the top of the chain and secure the clipboard system-wide. There are plenty of reasons to have a functional clipboard, but not one good reason contents should linger there for more than a minute or two.<br/><br/>Password managers have become popular lately, and if you use one, you've seen how they copy your password to the clipboard so you can paste it over in your browser and log into your accounts. Then what? Your password stays on the clipboard till another copy event or a reboot is what.<br/><br/>Even if you use a separate browser for things like banking, if you copy your password, you bring it back to your other browsers via the clipboard and expose it to web-based clipboard harvesting techniques.<br/><br/>My fix handles the problem for you in the background, clearing the clipboard contents automatically every minute. It does this with the xclip command line tool, a tiny script and <a href="https://en.wikipedia.org/wiki/Cron" target="_top" title="Link: https://en.wikipedia.org/wiki/Cron" class="">cron</a> 
. The one minute cron interval gives you enough time to get your copied passwords pasted, then it empties the clipboard. This repeats every minute, providing worry-free copying.<br/><br/>We need the <a href="https://github.com/astrand/xclip" target="_top">xclip</a> 
utility to clear the clipboard in the terminal. In apt-based distros, enter:<br/><br/> <b>sudo apt-get install xclip</b> 
<br/><br/>Lets test the utility in the terminal.&nbsp; First copy some text from anywhere, paste it somewhere else, then enter these two commands:<br/><br/> <b>touch blank<br/>xclip -selection clipboard blank</b> 
<br/><br/>then try pasting the text again - it should be gone. Now let's put the commands into a script. Create a script by entering (replacing leafpad with your text editor):<br/><br/> <b>leafpad nukeclipboard.sh</b> 
<br/><br/>and enter the following into the new file:<br/><br/> <b>#!/bin/sh<br/>touch blank &amp;&amp; xclip -selection clipboard blank</b> 
 <b><br/><br/>Save and close the file, then make it executable with:<br/><br/> <b>chmod +x nukeclipboard.sh</b> 
<br/><br/>Now to make the job run itself every minute. First beware, cron options differ from distro to distro. The following settings are for Ubuntu(based) distros and the process might be different in your distro, so <a href="https://en.wikipedia.org/wiki/Cron" target="_top" title="Link: https://en.wikipedia.org/wiki/Cron">rtm</a> 
.<br/><br/>To setup the cron job, go to the terminal and enter:<br/><br/> <b>crontab -e</b> 
<br/><br/>Scroll down past the #commented-out lines and enter the following line (replacing /home/user/ with the location of your script):<br/><br/> <b>* * * * * export DISPLAY=:0 &amp;&amp; /home/user/nukeclipboard.sh</b> 
<br/><br/>Now hit ctrl-o to bring up the save function, then hit enter to save your crontab. Finally, hit ctrl-x to exit the program. From now on your clipboard has a life-span of one minute.<br/><br/>About the cron entry above... cron has limitations regarding environment variables and when it fails, you can spend all day trying a hundred ways to fix it that don't work. After finding <a href="https://stackoverflow.com/questions/14296911/when-linux-system-calls-scripts-some-commands-dont-work-cron-if-up-d/24070707#24070707" target="_top" title="Link: https://stackoverflow.com/questions/14296911/when-linux-system-calls-scripts-some-commands-dont-work-cron-if-up-d/24070707#24070707">this easy fix</a> 
advising to set the DISPLAY, there's been no more trouble. Thanks <a href="https://stackoverflow.com/users/1618630/mike-q" target="_top">Mike Q</a> 
for this gem.<br/><br/>Now, you might go to paste something you've copied the very moment the clipboard's being emptied and find nothing there, but it's is a small price to pay for the security bump it gives you. If it's a problem, you can configure cron to run the job at any interval that works for you. Instructions for Ubuntu and kin are on <a href="https://help.ubuntu.com/community/CronHowto" target="_top" title="Link: https://help.ubuntu.com/community/CronHowto">this</a> 
page.<br/><br/>I hope this tutorial helps you get your clipboard locked down - comment below if you got the script working or have an even better way to do this.<br/><br/>dmt</b> 
</div> 
 <div class="readMore"> <a dont-color-link="true" href="/your-computer-s-clipboard-is-a-security-problem-fix-it-in-linux-with-xsel-and-cron"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 400.0ms;"> <a dont-color-link="true" href="/the-gpl-in-laymans-terms-free-as-in-what"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/copyleft-720x624.jpg)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/copyleft-720x624.jpg" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/the-gpl-in-laymans-terms-free-as-in-what">The GPL in Layman&rsquo;s Terms - Free as in What?</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>19 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~281505" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/the-gpl-in-laymans-terms-free-as-in-what" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">Through the glazed-over eyes of friends and family, past that painful look of well-intended but feigned interest, I can clearly see a fundamental lack of understanding about this free software I&rsquo;m constantly going on about. I&rsquo;ve always been the frugal type, so I think they just assume I choose it for the price. Ironically, I would happily pay for the free software programs I use daily, they just happen to come at no cost. And anyway, I DO pay.. just not to ACME Software Company for the yearly subscription. I go straight to the donation links of developers who write awesome code and pay them directly. It makes someone&rsquo;s day, feels <i>way</i> 
better than hitting &ldquo;BUY&rdquo; at the neighborhood app store, and costs only what I feel it&rsquo;s worth. Some days that&rsquo;s a little, other days it&rsquo;s more.<br/><br/>Returning to the reason for this essay, I decided to fix this disconnect and explain to those around me where the passion for using and sharing free software comes from. That decision turned into an open letter, which turned into this post. It was surprisingly difficult to distill the essence of a passion that has so many sides, and a winding road brought me to the conclusions herein. As with any other discipline, programming has endless details abound that only interest the initiated (hence blogs), and I only wanted to talk about why <b>I</b> 
think it&rsquo;s so important for <b>other people</b> 
to use free software, so I had to triple-distill my logic. I&rsquo;ll provide a bit of background first, then explain what I mean.<br/><br/> <b>Free vs <i>Free</i> 
</b> 
- Most people get &ldquo;free&rdquo;. If I say, &ldquo;go download Firefox, it&rsquo;s free&rdquo;, you understand that you won&rsquo;t have to run your credit card to get the download. However, in software licensing there&rsquo;s another kind of <i>free</i> 
that&rsquo;s more difficult to grasp at first. The romance languages have different words for each type of <i>free</i> 
, &ldquo;gratis&rdquo; for free as in you got something of value without paying for it, and &ldquo;libre&rdquo; for free as in liberty or the opposite of being locked up. This is reflected in the naming of open source programs like <a href="https://www.libreoffice.org/" target="_top">LibreOffice</a> 
and many others. In the software world, when you hear &ldquo;free as in beer&rdquo;, it means gratis. When you hear &ldquo;free as in speech&rdquo; or &ldquo;free as in freedom&rdquo;, it means libre. This distinction is important to understand because a computer program can be free to download, but not free at all in terms of studying its code or recycling it into another program (a good example being the freeware application Adobe Reader).<br/><br/>We are unable to study the workings of many major computer programs because the code is copyrighted and kept secret like the baked bean recipe only that dog knows (will he reveal it?). This kind of proprietary licensing scheme grants the user the right to use the program (through the ubiquitous <a href="https://en.wikipedia.org/wiki/End-user_license_agreement" target="_top">EULA</a> 
), but not the right to see the code or even own the program - ownership stays with the developer while you just use it. Conversely, for each open source computer program written and published, software developers choose a license that covers what can and cannot be done with the code. There are several dozen free and <a href="https://en.wikipedia.org/wiki/Comparison_of_free_and_open-source_software_licenses" target="_top">open source licenses</a> 
to choose from, each defining a different set of rules (or complete lack of rules) regarding how that code can be re-used. Some restrict the re-use of the software, while <a href="https://en.wikipedia.org/wiki/WTFPL" target="_top">others</a> 
don&rsquo;t. Incidentally, software can also be dedicated to the <a href="https://en.wikipedia.org/wiki/Public_domain" target="_top">Public domain</a> 
in lieu of being licensed at all.<br/><br/>In the late 1980s, the first open source licenses started to appear. The one that broke ground and led to the abundant collection of high-quality, open source programs available today is the Gnu General Public License ( <a href="https://en.wikipedia.org/wiki/GNU_General_Public_License" target="_top">GPL</a> 
). What made this licensing approach revolutionary at the time is that it granted users of a computer program the rights laid out in the <a href="https://en.wikipedia.org/wiki/The_Free_Software_Definition" target="_top">Free Software Definition</a> 
(the ability to use, study, change and redistribute the software) while requiring derivative works to be licensed under the same terms. This is known as a <a href="https://en.wikipedia.org/wiki/Copyleft" target="_top">copyleft</a> 
license and is considered &ldquo;protective&rdquo; because it preserves the rights in derivative works. This license ensures that a developer&rsquo;s code won&rsquo;t get locked up in someone else&rsquo;s alternatively re-licensed release of the original code. Using this license let&rsquo;s the developer share her code without worry that it will be used against her wishes down the road. The freedom to code without this worry started a software development rush that continues to this day. The results of this rush are a testament to the skill and tenacity of open source developers, and their fruits are proof that the open development model is a superior one.<br/><br/>Known as &quot;permissive&quot;, there are also open sources licenses that don&rsquo;t have such restrictions. The <a href="https://en.wikipedia.org/wiki/BSD_licenses" target="_top">BSD license</a> 
is a prime example of a permissive license. These licenses grant the user the right re-use the code in any program, even a proprietary one. For this reason, large companies will target code released under BSD-style licenses for re-use in proprietary software they have no intention of opening up. In recent years, legal challenges have been successfully leveled against companies for re-using software in violation of the GPL. This has resulted in a renewed and long-deserved respect for the terms of the GPL, and nowadays more companies are complying out of the gate when releasing new software (or just using BSD-licensed code).<br/><br/> <b>So Why Use Free Software?</b> 
- Returning again to the point here (and aware that opinions differ), I strongly believe that developing and releasing code into the open for peer review results in software of a higher quality, that runs faster, more safely and securely, with less problems, getting quicker bug fixes and providing more respect for user privacy than anything in the proprietary world. Indeed, both Apple and Google, who can easily afford their own in-house software development, instead chose to build their respective mobile platforms on top of existing open source operating systems: <a href="https://en.wikipedia.org/wiki/Linux" target="_top">Linux</a> 
for Android and the BSD-derived <a href="https://en.wikipedia.org/wiki/Darwin_(operating_system)" target="_top">Darwin</a> 
for iOS. If it&rsquo;s good enough for them, I think we can make it work on your desktop to read email, play music, video chat with friends, push office docs around, use the web with all the popular plugins, edit images, shop, bank, etc, etc.<br/></div> 
 <div class="readMore"> <a dont-color-link="true" href="/the-gpl-in-laymans-terms-free-as-in-what"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 600.0ms;"> <a dont-color-link="true" href="/this-script-updates-hosts-files-using-a-multi-source-unified-block-list-with-whitelisting"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/host-400x300.jpg)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/host-400x300.jpg" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/this-script-updates-hosts-files-using-a-multi-source-unified-block-list-with-whitelisting">This Script Updates Hosts Files Using a Multi-Source Unified Block List With Whitelisting</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>17 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~279255" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/this-script-updates-hosts-files-using-a-multi-source-unified-block-list-with-whitelisting" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">There are many helpful lists maintained online with constantly-updated hosts files that contain the domains of various Internet crap peddlers. Copying these lists into your hosts file can easily block a large number of domains that your system would be better off unable to connect to. This method works without installing a browser plug-in and will handle blocking for any browser (and any other program) on the system.<br/><br/>In this tutorial, I'll show you how to get Steven Black's <a href="https://github.com/StevenBlack/hosts" target="_top">Unified Hosts script</a> 
up and running in Linux. The script will keep your computer's hosts file updated (from multiple sources) with the latest known ad servers, phishing sites and other web scum, all while providing a nice, clean way to manage your own black/whitelists separately from the lists the script manages.<br/><br/>There are two caveats to note before putting 30,000 domains into your hosts file. First off, these huge lists contain servers that you might need unblocked in order to make an online purchase or for some other temporary situation. You'll know you have a problem when something on the web is broken since you messed with your hosts file. To remedy this, I'm going to show you how to make a handy on/off switch so you can quickly disable your blocklist to buy that Himalayan salt lamp (it's the ions). I still consider it a feature of these lists that all manner of things get blocked (it was only annoying until I thought of making that off switch). If you have a repeat problem with a blocked server that you need often, just add it to your whitelist file and you're all set.<br/><br/>The second problem is a slight performance hit because the system has to check the entire list each time a domain is called up. Maybe there's a small hit, but not big enough for me to ditch the list and let every connection through. However, consider yourself warned.<br/><br/>Hosts files block a server by directing requests to that server to either 127.0.0.1 or 0.0.0.0 - in other words, nowhere. Some say using zero's is a faster, less problematic way to accomplish the blocking. You can configure the script to use any blocking ip you want by executing it with the --ip option like &quot;--ip nnn.nnn.nnn.nnn&quot;, but the default is 0.0.0.0 and that's where I'm leaving it.<br/><br/>I used to do what Steven's script does by hand every once in a while, going to each site, copy/pasting their lists into my hosts file, doing a find-replace to change the one-twenty-seven's to zeros, etc. I knew the whole thing could be automated and there were tons of dupes, but I never took the time to address the problems. Since finding this script, that's now a forgotten chore.<br/><br/>Let's start by getting a fresh copy of Mr. Black's code downloaded (~150MB) so we can push some electrons around. You'll need git installed, so if it's not, go to the terminal and enter:<br/><br/> <b>sudo apt-get install git</b> 
<br/><br/>After it's done installing, enter:<br/><br/> <b>mkdir unifiedhosts</b> 
<br/> <b>cd unifiedhosts</b> 
<br/> <b>git clone</b> 
 <a href="https://github.com/StevenBlack/hosts.git"> <b>https://github.com/StevenBlack/hosts.git</b> 
</a> 
<br/> <b>cd hosts</b> 
<br/><br/>While your cursor blinks at Steven's script, let's talk about choices. The script has a few options and extensions that I wont cover here, but I figure if you got this far and you're interested, the <a href="https://github.com/StevenBlack/hosts/blob/master/readme.md" target="_top">readme.md</a> 
file can tell you all you need to know.<br/><br/>You need python installed to run the script, and which version you have matters. To find the version of Python you have, enter:<br/><br/> <b>python --version</b> 
<br/><br/>If you don't have python installed:<br/><br/> <b>sudo apt-get install python</b> 
<br/><br/>For Python 2.7, execute the script by entering &quot;python&quot; as I do below. For Python 3, replace &quot;python&quot; in the command with &quot;python3&quot;. Upon execution, the script makes sure it has the most recent version of each list and if not, grabs a new copy. It then writes a new hosts file, including anything in your black/whitelists. Let's give it a try using the -r option to replace our active hosts file and the -a option so the script wont ask any questions. Back to the terminal, and:<br/><br/> <b>python updateHostsFile.py -r -a</b> 
<br/><br/>The command will ask for your password so it can write to /etc/. For the newly updated list to be active, some systems require a good flush of the DNS cache. On the same hardware, I've observed different operating systems express very different behavior regarding the length of time it takes for a server to become reachable/unreachable after updating the hosts file without a flush. I've seen everything from instantaneously (Slackware) to never/reboot (Windows). There are commands to flush the DNS cache, but they're different on each OS and even each distro, so just reboot if the changes don't take.<br/><br/>Now it's as simple as adding your personal exceptions to the black/whitelist files and running the script whenever you want to update the hosts file. The script will adjust the resultant hosts file according to your specs, appending the file with your additions automatically each time you run it.<br/><br/>Finally, let's create the on/off switches. We need a script for each function, so go back to the terminal to create the OFF switch by entering (replacing leafpad with your text editor):<br/><br/> <b>leafpad hosts-off.sh</b> 
<br/><br/>and enter the following into the new file:<br/><br/> <b>#!/bin/sh</b> 
<br/> <b>sudo mv /etc/hosts /etc/hostsDISABLED</b> 
<br/><br/>And then make it executable with:<br/><br/> <b>chmod +x hosts-off.sh</b> 
<br/><br/>Similarly, for the ON switch:<br/><br/> <b>leafpad hosts-on.sh<br/></b> 
<br/>and enter the following into the new file:<br/><br/> <b>#!/bin/sh</b> 
<br/> <b>sudo mv /etc/hostsDISABLED /etc/hosts<br/></b> 
<br/>And finally make it executable with:<br/><br/> <b>chmod +x hosts-on.sh<br/><br/></b> 
All you need to do is create a shortcut somewhere for each script, labeling them HOSTS-ON and HOSTS-OFF and there you have it.<br/><br/>dmt<br/></div> 
 <div class="readMore"> <a dont-color-link="true" href="/this-script-updates-hosts-files-using-a-multi-source-unified-block-list-with-whitelisting"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 800.0ms;"> <a dont-color-link="true" href="/can-risc-v-linux-of-microprocessors-start-an-open-hardware-renaissance"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/riscv2_Nhb2HCZROKAxbYu2DePA-1122x812.png)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/riscv2_Nhb2HCZROKAxbYu2DePA-1122x812.png" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/can-risc-v-linux-of-microprocessors-start-an-open-hardware-renaissance">Can RISC-V - Linux of Microprocessors - Start an Open Hardware Renaissance?</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>16 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~278389" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/can-risc-v-linux-of-microprocessors-start-an-open-hardware-renaissance" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">I share the hope with many people that we will soon have access to modern, capable devices powered by both open source hardware ( <a href="https://en.wikipedia.org/wiki/Open-source_hardware" target="_top">OSH</a> 
) <i>and</i> 
software.<br/><br/>Open hardware is that which is fully documented and free to use, study, modify and reproduce for your own needs. Everything from the schematics to the PCB layout is all published, including the software that drives the hardware. There have been advancements in recent years and more hardware is being opened up, but the microprocessors in our pc's and other devices are stuck running one of the dominant, closed Instruction Set Architectures ( <a href="https://en.wikipedia.org/wiki/Comparison_of_instruction_set_architectures" target="_top" title="Link: https://en.wikipedia.org/wiki/Comparison_of_instruction_set_architectures">ISA's</a> 
) in the form of x86 on the desktop or an ARM variant in smartphones/tablets. Both of these ISA'a are closed source and are not candidates for an open device. Also, the many widely-used implementations of ARM like the A9 or Snapdragon add further proprietary layers to these already proprietary ISA's.<br/><br/> <a href="https://en.wikipedia.org/wiki/RISC-V" target="_top">RISC-V</a> 
is different. Introduced in 2010 by the researchers at UC Berkeley, RISC-V (pronounced risk-five) is built according to the same original <a href="https://en.wikipedia.org/wiki/Reduced_instruction_set_computing" target="_top">RISC</a> 
(Reduced Instruction Set Computing) CPU design that underlies other familiar ISA's such as ARM, MIPS, PowerPC and SPARC, but with the intention of being open and unencumbered by patents (Note: as of right now, the RISC-V specs are only free for private or educational use, with full openness planned for the future). The RISC design strategy is in opposition to the Complex Instruction Set Computing (CISC) design of the x86 family.<br/><br/>While RISC-V is not the only open ISA in existence, it's the only one poised to advance in a hurry. The RISC-V Foundation, which directs the development and adoption of the ISA, has some pretty big donors like Oracle, Western Digital, HP, Google, IBM, and Nvidia. I can think of a couple prominent chip manufacturers missing from that list. It seems that the big players have figured out that as with software, hardware will develop faster and better out in the open. Oh and also, you won't have to pay anyone to use it. A project like this hasn't been conquered any sooner because of the difficulty and cost involved in development. Now that an open result is actually what the big companies are after, the development money is rolling in.<br/><br/>RISC-V also has plenty of backing in the academic world. From its incubation at Berkeley to the over 35 University projects worldwide aiding in its development, there's no shortage of brilliant minds working on the project.<br/><br/>There's already progress happening in the background. On the software side, people are porting programs over to RISC-V and getting things booting up. Fedora has ported thousands of programs already - here's <a href="https://fedoraproject.org/wiki/Architectures/RISC-V" target="_top" title="Link: https://fedoraproject.org/wiki/Architectures/RISC-V">Fedora/RISC-V</a> 
booting up in QEMU:</div> 
 <div class="readMore"> <a dont-color-link="true" href="/can-risc-v-linux-of-microprocessors-start-an-open-hardware-renaissance"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 1000.0ms;"> <a dont-color-link="true" href="/hide-complex-passwords-in-plain-sight-and-give-your-brain-a-break"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/pw2_zW48hQwuQO6DAuC8G7LA-728x484.jpg)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/pw2_zW48hQwuQO6DAuC8G7LA-728x484.jpg" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/hide-complex-passwords-in-plain-sight-and-give-your-brain-a-break">Hide Complex Passwords in Plain Sight and Give Your Brain a Break</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>15 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~277839" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/hide-complex-passwords-in-plain-sight-and-give-your-brain-a-break" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">As far as people are concerned, there are essentially two types of passwords: the ones we can remember and the ones that are too complex for us to recall. We've learned the latter type is more secure, but it requires us to store impossible-to-memorize-password lists, creating a whole new set of problems. There are some <a href="https://lifehacker.com/four-methods-to-create-a-secure-password-youll-actually-1601854240" target="_top">clever tricks</a> 
to help our brains out a bit, but for most of us the limit of our memory is regrettable.<br/><br/>Not suffering from such memory limits, computers only see one kind of password - guessable. Regarding how long it takes a computer to crack a password, the major variables are: how much time the computer has to spend guessing, how many guesses per second it can try, and the complexity of the password. There are other factors, but strong passwords can exponentially increase the time it takes a computer to break through the gate, so naturally we want passwords to be <i>complicated</i> 
- just manageable.<br/><br/>When writing down or carrying around passwords is not desirable, yet you still want one that's more difficult than you can remember, there are options. By using a little imagination, you can open up endless ways to surreptitiously store complex, <a href="https://www.grc.com/passwords.htm" target="_top">perfect-style</a> 
passwords out in the open or glean them from the Internet at will.<br/><br/>This post is not intended to teach any one specific method (I only devised the one in the example below for training purposes to get people thinking outside their boxen), instead it aims to inspire different thinking regarding where to get reproducible data that can be leveraged for use in passwords. The way I see it, if we can't replace the feeble password altogether then we should at least teach it a few new tricks. The trick <i>here</i> 
lies in remembering a routine instead of an actual password, enabling you to pseudo-remember impossibly difficult strings like a savant.<br/><br/>For the example below, we'll use an image from Wikimedia Commons. You can save the image locally for when you need it or just go back to the web and get it each time - the Wikimedia images seem to sit in place forever, so we'll use it knowing we can easily find the exact same file again. You can use your own file in place of my example, it just has to be fixed and unchanging.<br/><br/>The file we'll grab is called &quot;IBM Personal Computer XT front.jpg&quot; which sits at <a href="https://commons.wikimedia.org/wiki/File:IBM_Personal_Computer_XT_front.jpg" target="_top">this</a> 
page. Save the jpg using the <a href="https://upload.wikimedia.org/wikipedia/commons/3/3c/IBM_Personal_Computer_XT_front.jpg" target="_top">Original file</a> 
link, then drop to a terminal in the directory where you saved it and enter:<br/><br/> <b>sha256sum IBM_Personal_Computer_XT_front.jpg | rev</b> 
<br/><br/>This command outputs the sha256 hash of the downloaded jpg in reverse, further obfuscating it. Your terminal should be displaying the following:<br/><br/>gpj.tnorf_TX_retupmoC_lanosreP_MBI&nbsp; f00059a089c6bb2f58620dfbf3104b29279947ead17f0650f3216013c0d05970<br/><br/>This gives us a high entropy, reproducible, 64 character hexadecimal string that can be called up at will anywhere there's Internet and used as a password, without hardly remembering a thing. Useful? Maybe. Lazy? Definitely.<br/><br/>In my example, you only need to remember the image location and the single command that gets the password out of it. In order for methods like these to be secure, you need to come up with something original, so my illustration should be adapted. There are countless other <a href="https://en.wikipedia.org/wiki/List_of_hash_functions" target="_top">hash functions</a> 
to choose from. You could instead use the sha384sum command which outputs a 96 digit hexadecimal string, for example. The possibilities are endless. Make it your own.<br/><br/>Finally, delete the jpg and enter one last command:<br/><br/>history -c<br/><br/>This clears the previous command from the terminal memory so when you close it, it wont be written to the .bash_history file.<br/><br/>dmt<br/><br/> <b>EDIT:</b> 
A reader from LXer.com chimed in and wrapped this routine up in a handy script, so I'm posting it here. The image can easily be replaced and the script cleans up on its way out. Nice. Thanks to dotmatrix.<br/><br/> <p> <b>mkdir ~/.some</b> 
<br/> <b>cd ~/.some</b> 
<br/> <b>wget <a href="https://s26.postimg.org/kh6n63t5l/pic1.png">https://s26.postimg.org/kh6n63t5l/pic1.png</a> 
</b> 
<br/> <b>sha256sum pic1.png |rev</b> 
<br/> <b>cd ~</b> 
<br/> <b>rm -r ~/.some</b> 
<br/></p> 
<br/></div> 
 <div class="readMore"> <a dont-color-link="true" href="/hide-complex-passwords-in-plain-sight-and-give-your-brain-a-break"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 1200.0ms;"> <a dont-color-link="true" href="/how-to-lift-vector-art-from-pdf-s-using-inkscape-on-linux"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/vector-pen-610x458.jpg)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/vector-pen-610x458.jpg" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/how-to-lift-vector-art-from-pdf-s-using-inkscape-on-linux">How To Lift Vector Art From PDF's Using Inkscape on Linux</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>11 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~275681" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/how-to-lift-vector-art-from-pdf-s-using-inkscape-on-linux" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">When graphics need to be produced billboard-size, you need nice, crisp <a href="https://en.wikipedia.org/wiki/Vector_graphics" target="_top">vector</a> 
versions of any logos or illustrations to be printed or else you'll get a pixelated effect like the image above (photos are another story altogether). These days, you can find most common graphics and the logos of large companies in vector format at sites like <a href="http://seeklogo.com/" target="_top">Seek Logo</a> 
.<br/><br/>But sometimes, a logo or other graphic is too complex for anyone in the volunteer community to have traced and shared with the public - or the company is not well known enough to have been noticed, so their logo can't easily be found and downloaded. This is where this PDF trick can make you a hero, seemingly pulling the artwork your team desperately needs out of thin air.<br/><br/>We start, as always, at Google. We'll search out the coke logo for this example. Note the colon and lack of spaces between &quot;filetype&quot; and &quot;pdf&quot; in the search query below:<br/><br/> <b>coca cola filetype:pdf</b> 
<br/><br/>That search brings us <a href="https://www.google.com/search?q=coca+cola+filetype%3Apdf" target="_top">these</a> 
results. At the time of writing, the top result is their <a href="https://www.coca-colacompany.com/content/dam/journey/us/en/private/fileassets/pdf/2015/09/2014-2015-sustainability-report.pdf" target="_top">Sustainability Report</a> 
. Great. Right-click, save link as, and download the PDF somewhere.<br/><br/>Now we need the great Inkscape vector graphics program to get to the artwork so if you don't have it, in Ubuntu/Mint, go to the terminal and enter:<br/><br/> <b>sudo apt-get install inkscape</b> 
<br/><br/>Next step: open Inkscape, click File, Open, choose the PDF you just downloaded, hit Open and you'll get this window:</div> 
 <div class="readMore"> <a dont-color-link="true" href="/how-to-lift-vector-art-from-pdf-s-using-inkscape-on-linux"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle "> <div class="inner clearfix wow" style="animation-delay: 1400.0ms;"> <a dont-color-link="true" href="/set-up-two-factor-auth-2fa-on-your-smartphone-linux-desktop-now"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/2fa-image-1280x720.jpg)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/2fa-image-1280x720.jpg" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/set-up-two-factor-auth-2fa-on-your-smartphone-linux-desktop-now">Set Up Two Factor Auth (2FA) on Your Smartphone &amp; Linux Desktop... now.</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>10 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~275089" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/set-up-two-factor-auth-2fa-on-your-smartphone-linux-desktop-now" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">It's now obvious that no system is completely immune to unauthorized access. The lowly password keeps failing and failing, yet we still haven't agreed on an alternative. Biometric authentication is promising, but so far has only bloomed in certain walled gardens. The best you can do right now is add layers of complexity to your login routines making your accounts harder to get to.<br/><br/>The problem with adding complexity is that it gets too complex and nobody wants to bother. The best solution for this is 2FA ( <a href="https://en.wikipedia.org/wiki/Multi-factor_authentication" target="_top">Two Factor Authentication</a> 
). You've seen 2FA at work when receiving a text from Google with a code that enables a login or gets you through an account setup. Securing logins with text messages no doubt increases security, but there are problems with relying on SMS for authentication. SMS fails to qualify as true two-factor, which is described as using a combination of something you know (a password) with something you have (supposedly your phone) to prove you are you. Since your phone number can be hijacked from the cellular company and your texts re-routed (or worse, cc'd) to another device, the phone doesn't fully qualify as something you (and only you) &quot;have&quot;.<br/><br/>The answer to this is to dismiss SMS and rely instead on an app or desktop program that employs the <a href="https://en.wikipedia.org/wiki/Time-based_One-time_Password_Algorithm" target="_top">Time-based One-time Password Algorithm (TOTP)</a> 
to generate a code that will get you logged in and keep others out. This code is entered along with your regular password, exponentially increasing the odds that you're the only one logging into your account. It's interesting to note that the software generating the code need not run on a system or phone that's connected to the Internet to output a good code - the system must only have the correct time (within 30 seconds or so) for it to work.<br/><br/>I'm going to describe the typical 2FA setup routine using an authenticator app, then I'll explain how to start generating codes in your Linux terminal using oathtool. Finally, I'll describe how to get nice menu shortcuts on your Linux machine that will open a terminal, display your auth code for you, then disappear after 30 seconds.<br/><br/>First let's get the app working. Since the software to generate these one-time passwords is open source and freely available, there are tons of apps that will do the job. I only recommend one: FreeOTP. It's open source, written by the Red Hat folks, and has a real no BS interface - and I like that a lot. Get it for iOS <a href="https://itunes.apple.com/us/app/freeotp-authenticator/id872559395?mt=8" target="_top">here</a> 
and Android <a href="https://play.google.com/store/apps/details?id=org.fedorahosted.freeotp&hl=en" target="_top">here</a> 
.<br/><br/>After you get the app running, head over to the great <a href="https://twofactorauth.org/" target="_top">Two Factor Auth</a> 
website and find a service you use that has implemented 2FA. They even break it down by what type of 2FA is offered by each site - to meet our goals in this tutorial, we're looking for a service that offers the Software Token method. Go login to that service and look around in the account settings till you find their 2FA setup. Every one is different, so there's no point in describing any details. Just get to the point where it shows you a QR code and tells you to scan it - but before you do anything, right-click the QR code image in your browser and save it for later in case you need to decode your key from it. Most services will also display the key under the QR code as a string of letters and numbers (like JBSWY3DPS3YK3PXP). If your service does display the key, copy it and save it for later. Just remember to treat the QR code and plaintext key like passwords and store them safely.<br/></div> 
 <div class="readMore"> <a dont-color-link="true" href="/set-up-two-factor-auth-2fa-on-your-smartphone-linux-desktop-now"></a> 
</div> 
</div> 
</div> 
</div> 
 <div class="postArticle lastArticle"> <div class="inner clearfix wow" style="animation-delay: 1600.0ms;"> <a dont-color-link="true" href="/iso-file-verification-the-laziest-way-possible"> <div class="blogImg" style="background-image:url(https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/iso-256x256.png)"><img src="https://irp-cdn.multiscreensite.com/58a25abc/dms3rep/multi/desktop/iso-256x256.png" onerror="handleImageLoadError(this)"/></div> 
</a> 
 <div class="postText clearfix"> <div class="postTitle"> <h3> <a dont-color-link="true" href="/iso-file-verification-the-laziest-way-possible">ISO File Verification - The Laziest Way Possible</a> 
</h3> 
</div> 
 <div class="authorBar"> <span>By - dmt</span> 
 <span>&bull;</span> 
 <span>09 Jan, 2017</span> 
 <span>&bull;</span> 
 <span class="blog-post-comments-count" data-disqus-id="58a25abc~273063" data-disqus-short-name="dmt-linux" data-href="http://www.darrentoback.com/iso-file-verification-the-laziest-way-possibleiso-file-verification-the-laziest-way-possible" data-comment="Comment" data-comments="Comments"></span> 
</div> 
 <div class="postDescription">This is a little trick to shave a few seconds off your daily distrohopping efforts. Every time you download an ISO file, you verify it using a hashing algorithm like md5, or more often these days, sha256. So for instance, if you download ubuntu-16.04-desktop-amd64.iso and run it through sha256 at the terminal like so:<br/><br/> <b>sha256sum ubuntu-16.04-desktop-amd64.iso</b> 
<br/><br/>...the response you get is:<br/><br/> <b>4bcec83ef856c50c6866f3b0f3942e011104b5ecc6d955d1e7061faff86070d4&nbsp;&nbsp; ubuntu-16.04-desktop-amd64.iso</b> 
<br/><br/>Now the lazy part. Simply copy the resulting hash and paste it into a search engine <a href="https://www.google.com/search?q=4bcec83ef856c50c6866f3b0f3942e011104b5ecc6d955d1e7061faff86070d4" target="_top">like so</a> 
. Without even clicking on a link, you can typically determine just from the results that you have a good file.<br/><br/>dmt</div> 
 <div class="readMore"> <a dont-color-link="true" href="/iso-file-verification-the-laziest-way-possible"></a> 
</div> 
</div> 
</div> 
</div> 
</div> 
 <div></div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
 <div class="dmFooterContainer"> <div id="fcontainer" class="u_fcontainer f_hcontainer dmFooter p_hfcontainer"> <div dm:templateorder="14" class="dmFooterResp dmFullFooterResp" id="1045865041"> <div class="dmRespRow dmDividerRow" id="1333043071"> <div class="dmRespColsWrapper" id="1127920853"> <div class="large-12 medium-12 small-12 dmRespCol" id="1866252423"> <div class="dmDividerWrapper clearfix" id="1565741547"><hr class="dmDivider defaultDivider" id="1026657584"/></div> 
</div> 
</div> 
</div> 
 <div class="dmRespRow dmFooterContent u_1855901642" id="1855901642"> <div class="dmRespColsWrapper" id="1262196393"> <div class="u_1096360864 dmRespCol small-12 dmFooterCol medium-12 large-12" id="1096360864"> <h3 class="dmFooterDefaultH3" id="1947457076">Follow Us</h3> 
</div> 
</div> 
</div> 
 <div id="1236746004" dmle_extension="powered_by" wr="false" icon="true" surround="false" data-dmtmpl="true"></div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
</div></div>

<!--  Add full CSS and Javascript before the close tag of the body if needed -->
<script type="text/javascript">
(function() {
 	var campaign = (/utm_campaign=([^&]*)/).exec(window.location.search);
 	
 	if (campaign && campaign != null && campaign.length > 1) {
 		campaign = campaign[1]; 		
 		document.cookie = "_dm_rt_campaign=" + campaign + ";expires=" + new Date().getTime() + 24*60*60*1000 + ";domain=" + window.location.hostname + ";path=/";
 	}
}());
</script>
<script type="text/javascript">
  var _dm_gaq = {};
  var _gaq = _gaq || [];
  var _dm_insite = [];
  
  
  _dm_gaq.siteAlias = '58a25abc';
  _dm_gaq.systemAggregatedGaqID = 'UA-7265702-9';    
  _dm_gaq.externalGaqID = '';
  
  
  _gaq.push(['_gat._forceSSL']);
  
  if(_dm_gaq.systemAggregatedGaqID && (_dm_gaq.systemAggregatedGaqID != _dm_gaq.systemGaqID)){
     // track aggregated account
    _gaq.push(['b._setAccount', _dm_gaq.systemAggregatedGaqID]);
    _gaq.push(['b._setAllowLinker', true]);
    _gaq.push(['b._setVar', _dm_gaq.siteAlias]);
    _gaq.push(['b._setCustomVar', 1, 'product', 'DM_DIRECT',  2 ]);
    _gaq.push(['b._setCustomVar', 2, 'plan', 'BUSINESS_PLUS',  2 ]);
    _gaq.push(['b._setCustomVar', 3, 'dfooter', 'false',  2 ]);
    _gaq.push(['b._setCustomVar', 4, 'sitetype', '1',  2 ]);
    _gaq.push(['b._trackPageview' ]);
    pushInsiteImpressions('b._trackEvent');
   }
       
   if(_dm_gaq.externalGaqID && _dm_gaq.externalGaqID!= '') {    	    	
     _gaq.push(['c._setAccount', _dm_gaq.externalGaqID]);                      
     _gaq.push(['c._setVar', _dm_gaq.siteAlias]);
     _gaq.push(['c._setDomainName', 'darrentoback.com']);
     _gaq.push(['c._setAllowLinker', true]);
     _gaq.push(['c._trackPageview' ]);
     pushInsiteImpressions('c._trackEvent');
   }

   function pushInsiteImpressions(category) {
   	$.each(_dm_insite, function(idx, rule) {
   		_gaq.push([ category, 'insite_impression' , _dm_gaq.siteAlias, rule.ruleType + '__' + rule.ruleId, ]);
   	});
   }
(function() {
	var ga = document.createElement('script');
	ga.type = 'text/javascript';
	ga.async = true;
  
	ga.src = 'https://dd-cdn.multiscreensite.com/jscache/ga.js';
	var s = document.getElementsByTagName('script')[0];
	s.parentNode.insertBefore(ga, s);
})();
	
;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
};p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,"script","//d32hwlnfiv2gyn.cloudfront.net/sp-2.0.0-dm-0.1.min.js","snowplow"));
window.dmsnowplow  = window.snowplow;

dmsnowplow('newTracker', 'cf', 'd32hwlnfiv2gyn.cloudfront.net', { // Initialise a tracker
  appId: '58a25abc'
});

dmsnowplow('trackPageView')
$.each(_dm_insite, function(idx, rule) {
	//('trackStructEvent', 'category','action','label','property','value');
 			dmsnowplow('trackStructEvent','insite', 'impression' ,rule.ruleType,  rule.ruleId);
 			$(document).ready(function(){
 				$.DM.events.trigger('event-ruleTriggered', {value: rule})}
 			);
 		});
   </script>

<div style="display:none;" id="P6iryBW0Wu"></div>

<!-- photoswipe markup -->







<!-- Root element of PhotoSwipe. Must have class pswp. -->
<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

    <!-- Background of PhotoSwipe. 
         It's a separate element as animating opacity is faster than rgba(). -->
    <div class="pswp__bg"></div>

    <!-- Slides wrapper with overflow:hidden. -->
    <div class="pswp__scroll-wrap">

        <!-- Container that holds slides. 
            PhotoSwipe keeps only 3 of them in the DOM to save memory.
            Don't modify these 3 pswp__item elements, data is added later on. -->
        <div class="pswp__container">
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
        </div>

        <!-- Default (PhotoSwipeUI_Default) interface on top of sliding area. Can be changed. -->
        <div class="pswp__ui pswp__ui--hidden">

            <div class="pswp__top-bar">

                <!--  Controls are self-explanatory. Order can be changed. -->

                <div class="pswp__counter"></div>

                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>

                <button class="pswp__button pswp__button--share" title="Share"></button>

                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>

                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>

                <!-- Preloader demo http://codepen.io/dimsemenov/pen/yyBWoR -->
                <!-- element will get class pswp__preloader--active when preloader is running -->
                <div class="pswp__preloader">
                    <div class="pswp__preloader__icn">
                      <div class="pswp__preloader__cut">
                        <div class="pswp__preloader__donut"></div>
                      </div>
                    </div>
                </div>
            </div>

            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
                <div class="pswp__share-tooltip"></div> 
            </div>

            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
            </button>

            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
            </button>

            <div class="pswp__caption">
                <div class="pswp__caption__center"></div>
            </div>

        </div>

    </div>

</div><!-- note these also must be called after ajax -->
<script>
var dmForceShare = false;
if (dmForceShare || $("#shareSection").length > 0 || $(".dmShare").length > 0 ){dmLoadShare();}
function dmLoadShare(){
/* google plus shares */
$.ajax({url: "https://apis.google.com/js/plusone.js",dataType: "script",success: function () {}});
/* linked in shares */
$.ajax({url: "https://platform.linkedin.com/in.js",dataType: "script",success: function () {}});
/* Twitter Shares */
$.ajax({url: "https://platform.twitter.com/widgets.js",dataType: "script",success: function () {}});
}
</script>
<div id="fb-root" data-locale="en_US"></div>

<!--  site ID: 594378 -->
<!--  Alias: 58a25abc -->
<!--  device: DESKTOP -->
<!--  page ID: 147792324 -->
<!--  generated: Thu Jan 01 00:00:00 UTC 1970 -->
<!--  Server: d1-run-as-0bf1dda7214d03f7b -->
<div class="dmPopupMask" id="dmPopupMask"></div>
<div id="dmPopup" class="dmPopup">
	<div class="dmPopupCloseWrapper"> <div class="dmPopupClose dm-icon-x_close_popup oneIcon" onclick="dmHidePopup(event);"></div> </div> 
 	<div class="dmPopupTitle"> <span></span> Share by:</div> 
	<div class="data"></div>
</div><script>
// Collects client data and updates cookies used by smart sites
var expireDays = 365,visitLength = 30 * 60000;
$.setCookie("dm_timezone_offset", (new Date()).getTimezoneOffset(), expireDays);
function setSmartSiteCookies() {
	setSmartSiteCookiesInternal("dm_this_page_view","dm_last_page_view","dm_total_visits","dm_last_visit");
}
$.DM.events.on("afterAjax", setSmartSiteCookies);
setSmartSiteCookies();
</script>
<script type="text/javascript">
$.extend(Parameters,{
 AjaxContainer : "div.dmBody",
 WrappingContainer : "div.dmOuter",
 HomeUrl : "https://www.darrentoback.com/",
 SiteAlias : "58a25abc",
 SiteId : "594378",
 SiteType : eval(Base64.decode("J0RVREFPTkUn")),
 ExternalUid: null,
 IsSEOFriendlyLinks : true,
 IsSiteMultilingual: false,
 InitialPageAlias : "d1-internal-blog-post",
 InitialEncodedPageAlias : "ZDEtaW50ZXJuYWwtYmxvZy1wb3N0",
 IsFromScratch : "false",
 CurrentPageUrl : "null",
 IsCurrentHomePage : false,
 classicLink : "",
 AllowAjax : true,
 AfterAjaxCommand : null,
 HomeLinkText:"Back To Home",
 UseGalleryModule : false,
 CurrentThemeName : "Layout Theme",
 ThemeVersion : "152",
 DefaultPageAlias : "",
 RemoveDID : true,
 LayoutVariationID : {desktop : 5}, 
 LayoutID : {desktop : 9},
 WidgetStyleID : null,
 IsHeaderFixed: false,
 IsHeaderSkinny: false,
 IsBfs: true,
 LayoutParams : {_manifestId : 10004,_device : "desktop"},
 StorePageAlias: "null",
 StorePath: "",
 StoreCleanUrl:true,
 NotificationSubDomain: "darrentoback",
 HasCustomDomain: true,
showCookieNotification: false,
cookiesNotificationMarkup: 'null',
translatedPageUrl: '',
isFastMigrationSite: false

});
$.extend(Parameters.NavigationAreaParams,{
 ShowBackToHomeOnInnerPages : true,
 NavbarSize : 4,
 NavbarLiveHomePage : "https://www.darrentoback.com/",
 BlockContainerSelector : ".dmBody",
 NavbarSelector : "#dmNav:has(a)",
 SubNavbarSelector : "#subnav_main"
});
$.extend(Parameters.LayoutParams, {_navigationAnimationStyle : 'slide'});

Parameters.NavigationAreaParams.MoreButtonText = 'MORE';

Parameters.NavigationAreaParams.LessButtonText = 'LESS';
Parameters.HomeLinkText = 'Home';
</script>

<script>

jQuery(window).load(function () {
	try {
		var w = window.parent.document,
		        isPreviewEditor = w && w.getElementById('PreviewPaneWrapper') && w.getElementById('PreviewPaneWrapper').getAttribute('device') === "all",
		        isPreviewNoEditor = w && w.body.className.indexOf('onePreviewBody') > -1,
		        isPreviewMultiScreen = isPreviewEditor || isPreviewNoEditor;
		//if(isPreviewMultiScreen) {$.layoutManager.initLayout();}
		jQuery.DM.updateIOSHeight();
	} catch(e){}; 
});
</script>

<!--  End Script tags -->

</body>
</html>